Maersk tracking links

Incident Report for Link Parcel4you

Resolved

This incident has been resolved.
Posted Jun 03, 2026 - 10:11 UTC

Update

We are pleased to inform you that the issue with Maersk's TrackYourParcel link has now been resolved.

You should now be able to access the tracking page without encountering the “Access denied” message. The technical team has identified and fixed the root cause to ensure normal functionality.
Posted May 18, 2026 - 12:58 UTC

Identified

Maersk are currently experiencing issues with their tracking links.

They are actively investigating the matter, and we are working closely with them to resolve the issue as quickly as possible.

We sincerely apologize for the inconvenience and appreciate your patience and understanding while this is being addressed.
Posted May 18, 2026 - 08:28 UTC
This incident affected: Carrier connections (Maersk E-Delivery).