International delays France and Spain
Incident Report for Link Parcel4you
Resolved
This incident has been resolved.
Posted Jan 10, 2025 - 11:32 UTC
Update
We’ve been informed about the possible impact of the delivery of post and packages to the below destinations.

France
Due to high volumes at our partner informed us about the possible impact of the delivery of post and packages.

Expected delays: 1 day

Spain
All offices except Paiporta and Catarroja are opened and operating.
Slow processing the backlog of aprox 1 week when the roads are in good conditions.
Concerns; VALENCIA + MÁLAGA + TARRAGONA

Expected delay: 1 day

Our network partners will make every effort to ensure deliveries in the best conditions.
Posted Dec 12, 2024 - 10:15 UTC
Update
We are continuing to monitor for any further issues.
Posted Nov 21, 2024 - 07:20 UTC
Update
We are continuing to monitor for any further issues.
Posted Nov 21, 2024 - 07:18 UTC
Monitoring
We’ve been informed about the possible impact of the delivery of post and packages to the below destinations.

United Kingdom
Snow and ice are continuing to impact some of our delivery and collection operations.

Leeds, Middleton, and Exeter and their surrounding regions are seeing disruption due to snow and ice on the roads.

Weather warning can be found here: UK weather warnings - Met Office

Expected delay: 1-2 days

France
We’ve been informed about the possible impact of the delivery of post and packages to the below destination.

France
Due to high volumes at our network partner Colis Privé informed us about the possible impact of the delivery of post and packages.

Expected delays: 1 day

Our network partners will make every effort to ensure deliveries in the best conditions.
This situation for our network partners is in constant coordination and we will continuously inform you about the current status over the next few days.

Expected delay: 1 day

Spain
All offices except Paiporta and Catarroja are opened and operating.
Slow processing the backlog of aprox 2 weeks when the roads are in good conditions.
Concerns; VALENCIA + MÁLAGA + TARRAGONA

Italy
Upcoming strikes announced by the carrier SDA: Friday 13th of December 2024.

Expected delay: 1 day

Our network partners will make every effort to ensure deliveries in the best conditions.
Posted Nov 19, 2024 - 08:07 UTC
This incident affected: Carrier connections (Maersk E-Delivery).