The technical issues have been resolved, and all systems are now operating normally. Bring is continuing to closely monitor their systems to ensure ongoing stability and performance. Thank you for your patience, and we apologize for any inconvenience this may have caused.
Posted Sep 01, 2026 - 06:09 UTC
Identified
Bring is currently experiencing technical issues that may affect some of their services. As a result, some customers may experience instability. They are working on resolving the issue and apologize for any inconvenience this may cause: https://status.bring.systems/
Posted Aug 28, 2026 - 13:54 UTC
This incident affected: Carrier connections (Bring).