Maersk E-delivery - SmartLabel Issues

Incident Report for Link Parcel4you

Resolved

Please be informed that Maersk E-delivery are now able to create labels again.

The production issue affecting shipment creation and Smart Label generation has been resolved, and the service is now fully operational.

New label requests are being processed successfully without any impact.

Please note that labels that failed during the outage will not be automatically retried.
To complete the affected shipments, users must manually re-trigger label generation by reprocessing the parcels or repeating the label creation process.
Posted Jun 03, 2026 - 13:16 UTC

Identified

Please be advised we are currently experiencing an issue affecting Maersk E-delivery SmartLabel system, which is impacting operations with various carriers.

The technical team is actively working to resolve the situation and restore full service as quickly as possible.
Posted Jun 03, 2026 - 10:12 UTC
This incident affected: Carrier connections (Maersk E-Delivery).